[MlMt] hover over link to view it?

Guillaume Barrette guitest02 at gmail.com
Wed Mar 17 10:07:58 EDT 2021

Before deleting your preferences at `~/Library/Application 
Support/MailMate/` I would backup those files. As a workaround myself I 
often simply change the name of the directory in the Application Support 
directory so the application doesn't see it. Ex: Change "MailMate" 
directory to "MailMate-backup"

As for the icons missing in the preferences. I think I saw this 
behaviour when I briefly tested the MailMate beta. I then moved back to 
the standard version and everything is fine there. I'll have a look 
later and see if it's still the case, but myself I'm on the standard 
version: Version 1.13.2 (5673)



On 17 Mar 2021, at 9:50, Eric Sharakan wrote:

> Sounds like there might be corruption in the application's internal 
> resources on your system.  Have you tried the "nuclear" option?  
> Delete the app, as well as the entire contents of your 
> ~/Library/Application Support/MailMate/ directory (saving any manual 
> customizations you might have made in there), and re-install.
> I expect you'll lose things like any smart mailboxes you have 
> configured, tags you have applied to messages (depending if your IMAP 
> server supports preserving client-side MAP keywords), etc.  Perhaps 
> others have tricks to preserve those...
> -Eric
> On 17 Mar 2021, at 9:38, Shoshanna Green wrote:
>> Thanks to Eric's comment in another thread, I've discovered why I 
>> hadn't seen any updates in months, and have updated to 5777 (under 
>> 10.13.6 High Sierra) -- but I still do not see URLs pop up when I 
>> hover over a link, and I still do not see icons in the Preferences 
>> tabs. The latter is a minor annoyance, but the former is a major one; 
>> can anyone help me debug this? Please?
>> On 25 Jan 2021, at 15:32, Shoshanna Green wrote:
>>> I'm bumping this in hopes of new ideas, and maybe Benny chiming in: 
>>> I'm running 5757 under High Sierra 10.13.6 and I have no idea why I 
>>> don't see URL popups when I hover the mouse over a link in a 
>>> message, but I sure wish I did!
>>> On 5 Jan 2021, at 10:37, Shoshanna Green wrote:
>>>> Hm -- could the fact that I do not see a URL displayed when I hover 
>>>> over a link in a message be related to the fact that I also don't 
>>>> see any icons for the Preferences tabs? See 
>>>> https://imgur.com/OeBLfm8 -- each tab is available and has its text 
>>>> label, but is missing the icon that I presume ought to appear above 
>>>> the text.
>>>> On 31 Dec 2020, at 11:00, Shoshanna Green wrote:
>>>>> A reasonable question, but no, I'm not.
>>>>> Glenn's message, which just arrived, reminds me that I should add 
>>>>> that I'm running MailMate 5757 under High Sierra 10.13.6. Maybe 
>>>>> the lack of URL popups is due to my OS being behind the times?
>>>>> On 31 Dec 2020, at 10:30, Guillaume Barrette wrote:
>>>>>> Hi,
>>>>>>    Just an idea, may not be related since I don't know exactly 
>>>>>> how this popup is coded, but are you using a custom stylesheet 
>>>>>> for your email viewer? Maybe this could interfere with the popup
>>>>>> --
>>>>>> Guillaume
>>>>>> On 31 Dec 2020, at 10:12, Shoshanna Green wrote:
>>>>>>> Huh -- I'm on 5757 and I'm not seeing it, and haven't for ages. 
>>>>>>> I'm talking not about links where the URL is explicitly shown in 
>>>>>>> the message text, as in Guillaume's message, but about encoded 
>>>>>>> text links, such as in daily news summaries from newspapers: the 
>>>>>>> text says "More Things Are Terrible, Say Sources" and clicking 
>>>>>>> it will take me to an article on the paper's website. Encoded 
>>>>>>> links like those show no popup URLs for me; hovering over them 
>>>>>>> does nothing.
>>>>>>> I restart MailMate at least daily, and I just tried turning my 
>>>>>>> VPN off and restarting MM again, in case that was the problem 
>>>>>>> (even though I had already set MM to bypass the VPN, because it 
>>>>>>> causes SMTP problems in sending mail). No joy. Is there 
>>>>>>> something else that could be blocking this? I can't see anything 
>>>>>>> in the preferences...
>>>>>>> Shoshanna
>>>>>>> On 31 Dec 2020, at 10:02, Guillaume Barrette wrote:
>>>>>>>> Working as well on my side in the non-beta MM version: 5673
>>>>>>>> Have you tried a restart of MailMate and see if this comes 
>>>>>>>> back?
>>>>>>>> From here, I see that MM doesn't show it if the address 
>>>>>>>> displayed is the same as the actual one, maybe that what you're 
>>>>>>>> seeing?
>>>>>>>> https://lists.freron.com/mailmate/2016-September/006940.html
>>>>>>>> Hope this help!
>>>>>>>> --
>>>>>>>> Guillaume
>>>>>>>> On 31 Dec 2020, at 9:56, Ian Petersen wrote:
>>>>>>>>> Shoshanna,
>>>>>>>>>> I really miss being able to hover over a link in an email and 
>>>>>>>>>> see where it would send me. Might that feature return?
>>>>>>>>> Seems to be working fine here in 5757 …
>>>>>>>>> Cheers
>>>>>>>>> Ian
>>> Shoshanna Green (she/her)
>>> shoshannag at gmail.com
>> Shoshanna Green (she/her)
>> shoshannag at gmail.com
>> _______________________________________________
>> mailmate mailing list
>> mailmate at lists.freron.com
>> https://lists.freron.com/listinfo/mailmate
> _______________________________________________
> mailmate mailing list
> mailmate at lists.freron.com
> https://lists.freron.com/listinfo/mailmate
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freron.com/pipermail/mailmate/attachments/20210317/23ee25ab/attachment.htm>

More information about the mailmate mailing list