[MlMt] Hang on interaction with keychain access?

Benny Kjær Nielsen mailinglist at freron.com
Fri Nov 23 16:06:07 UTC 2012

On 19 Nov 2012, at 20:27, Benny Kjær Nielsen wrote:

> On 19 Nov 2012, at 19:53, Seebs wrote:
>> At this point, my system had entered a state wherein ANY activity 
>> which required keychain access would simply hang. Would ignore 
>> SIGTERM. Could not be debugged. Couldn't even be STARTED under the 
>> debugger. Entire system unusable. Couldn't change network settings or 
>> anything.

It seems that the problem can be fixed by killing a process named 
`authorizationhost` (I wish I figured this out sooner).

>> SIGHUP worked to close things, and rebooting got me back to normal, 
>> but with the same problem if I tried to start MailMate.
>> Went into keychain access, changed settings there, all is well.
> Thanks for the detailed description of this problem!! I had a similar 
> report earlier today, but it was unclear what exactly triggered this 
> problem (the extreme hanging). I haven't located the bug yet, but at 
> least I know where to look now. A fairly recent change to part of the 
> certificate related code is a prime suspect (some refactoring done 
> while implementing S/MIME support).
> I'll focus on this problem tomorrow and try to get an update out as 
> soon as possible.

Took a lot more than just a day. I've been fighting this problem on and 
off for several days. Some of my findings are documented here: 

I've reported the hang to Apple since it shouldn't hang even if I do 
something wrong. The problem seems to only affect 10.7.5. My current 
workaround for the problem involves rebooting into a 10.7.0 partition 
when codesigning MailMate before distribution. I'll continue to 
investigate the problem since this is obviously not an ideal workflow.

A test release of MailMate is available. Hold down ⌥ when clicking 
Check Now to fix it. (Note that the tagging GUI has been temporarily 

Again, thanks for reporting this issue.


More information about the mailmate mailing list