[MlMt] Hang on interaction with keychain access?

Benny Kjær Nielsen mailinglist at freron.com
Mon Nov 19 19:27:54 UTC 2012

On 19 Nov 2012, at 19:53, Seebs wrote:

> At this point, my system had entered a state wherein ANY activity 
> which required keychain access would simply hang. Would ignore 
> SIGTERM. Could not be debugged. Couldn't even be STARTED under the 
> debugger. Entire system unusable. Couldn't change network settings or 
> anything.
> SIGHUP worked to close things, and rebooting got me back to normal, 
> but with the same problem if I tried to start MailMate.
> Went into keychain access, changed settings there, all is well.

Thanks for the detailed description of this problem!! I had a similar 
report earlier today, but it was unclear what exactly triggered this 
problem (the extreme hanging). I haven't located the bug yet, but at 
least I know where to look now. A fairly recent change to part of the 
certificate related code is a prime suspect (some refactoring done while 
implementing S/MIME support).

I'll focus on this problem tomorrow and try to get an update out as soon 
as possible.


More information about the mailmate mailing list