[MlMt] Rules not firing - even when manually executed

Robert Wall rswall at rswall.com
Thu Feb 18 08:14:50 EST 2021

Just flagging this as solved for me. I went to do updates, and for some 
reason I was on a beta / pre-release version. Mailmate prompted me to 
downgrade, I did, and all is well.

Worth noting. :)

On 16 Feb 2021, at 10:30, Robert Goldman wrote:

> On 16 Feb 2021, at 8:14, Robert Wall wrote:
>>> However, if I change it to ...
>>> 1. edit rules for mailbox 'foo'
>>> 2. switch to some other mailbox (doesn't matter which one)
>>> 3. switch back to mailbox 'foo'
>>> 4. run rules manually
>>> ... then the rules work as expected.
>> I just tried this, and no joy unfortunately. I even quit and 
>> re-launched.
> I have been having the exact same problem.  Interestingly, the use of 
> rules in defining smart mailboxes seems to be fine, and at least some 
> of my old rules are working. I just cannot seem to get a new rule to 
> work.
> I have seen anomalies in development of rules, too -- I was trying to 
> build them using tagging as the action (so I could easily see the 
> effect of a rule), I would add and then delete conjuncts to a rule and 
> this change was not idempotent: the rules would stop working with the 
> new conjunct, but would not start working again when I deleted it.
> I have a vague memory of Benny saying there was some way to debug the 
> rules (by enabling some kind of MM logging to the screen), but I have 
> forgotten how to do it. 😢 I think I had to toggle some preference 
> and then start MailMate from the command line...
> _______________________________________________
> mailmate mailing list
> mailmate at lists.freron.com
> https://lists.freron.com/listinfo/mailmate

More information about the mailmate mailing list